Pi + 7" touchscreen + bookworm (debian 12) problem


Thanks for ALL your work …
I had to do a fresh build on my Rpi3b - w/7" screen because it was still running buster.

(created a bookworm 32bit sdcard)
All went well, except I seem to have lost the touch screen ‘touch’ ability?
I seem to recall there was an issue way back when, that I never quite understood clearly. Something about not being able to use a mouse & touch on the same display - and required setting the cursor=1 or 0 one way or the other. I believe mine was set for 0 and was working on this same setup under buster.

It is currently set to 0 - but my touch points don’t work. If I change it to cursor=1 it still doesn’t work. But if I plug in a mouse with set to 1 it does work.

I have another touchscreen setup on a RasPad3 it works fine (cursor=0) but it is running bullseye.

I also updated all of my Windows 11 PC’s to v23.10.1 – all work perfectly so far.

Any feedback would be appreciated. Not a real big deal, as I can always connect a mouse to change things.

The one big drawback is that VNC no longer works under bookworm. I tried a fallback method that was suppose to work - by switching to X11 instead of Wayland, but that didn’t seem to get VNC to work.

I don’t really use remote to tweak things on wfpiconsole - so I can live with things as they are now. I’ve heard that TigerVNC or some other client may be working? Not sure, as it’s not a priority at the moment.

[[[ EDIT ]]]

Nevermind, I decided to downgrade, unrelated to the wfpiconsole issues…
It appears that ‘bookworm’ is not even really recommended on the rpi3b as it does NOT even appear on the list provided from the latest Rpi Imager.

Do a little more research on VNC. It’s (not well) documented on the raspi site. One link on the raspi forums is [Solved] VNC server on Bookworm - Raspberry Pi Forums

1 Like

Yeah, the fixes I’ve tried including the link you provided - won’t work with the 32bit version that I’ve installed.

Update: Pi OS Bookworm compatibility
We are currently exploring compatibility of RealVNC Viewer and RealVNC Server when running Pi OS Bookworm in X11 mode, instead of Wayland (wayfire).

Note, the below applies to 64-bit versions of Pi OS Bookworm only. We are aware of an issue preventing RealVNC Server running under 32-bit versions of Pi OS Bookworm.

This was copied from RealVNC’s website.

Since I’m upgrading my good old wfpiconsole I had to re install the card (the upgrade between os’s was to much and ended in ****)

The actual kernel (October 2023) hasn’t got all things needed to drive the screen (it work but no touching works).

work around is to terminal in (ssh or via screen + mouse and keyboard)

sudo rpi-update

let it run and it will ask to reboot at the end

that’s it, touching part is ok again.

Does the fix suggested by @eric make the touchscreen work again?

No, the fixes ONLY applied to 64bit version. I had installed the 32bit.

I no longer have that setup running so I won’t be able to help test or resolve the issue.

It was an easier solution for me just to clone the system (bullseye) I had running on my RasPad3 and just rename the hostname.

the one I mention was applied on 32bit bookworm.

Oh … sorry … I thought he was referring to the post by @vinceskahan.

my bad.


I checked to see if I had an IMG of that setup to try , but I didn’t.

OK, no problem. Glad you have manage to find a setup that works for you :slight_smile: