Sager Fcst "ERROR: Missing METAR information. Forecast will be regenerated in 60 minutes."

I’ve been seeing this for the past 3 days. Anyone else with a ‘wfpiconsole’ noticing this? It could be an issue at “CheckWx`s” house . . . OR . . . it could be an issue with the nearest ASOS site from KOFF.

I checked and my CheckWx username, passwd, Email. . .and API Key are all still valid and the API Key is still currently listed in the wfpiconsole.ini file on the RPi4 device.

I have the settings on ‘wfpiconsole’ to generated a new Sager Fcst every 3 hours beginning at Midnight LDT (12:00 am) daily.

At 16Z today. . .I revoked my previous CheckWx API Key. . . and REgenerated a new one then updated it in “wfpiconsole.INI” file. This did not help. Still getting the ERROR message on ‘wfpiconsole’ when touching the Sager button. I even sent a message to CheckWX Support. . .but have not heard back from them.

I just checked, I’m getting the same error. I don’t use Sager, so I hadn’t noticed it.

I think I MAY have found the problem on my end. That is. . .the Offutt AFB Tower Information “Echo” on 273.50 MHz (UHF) is broadcasting the latest METAR obs for KOFF. . .but. . .the “skyvector” chart for the Omaha area. . . shows that NO METAR observation is listed for KOFF.

@lauraf13 since you are getting the same result. . .there may be an issue with the file in the “wfpiconsole” directory? I hadn’t messed with any of those files what-so-ever (for fear of dong something I’d regret).

Wait – Lo and Behold. . .my Sager Forecast just updated updated at 12:00pm CDT! . . .after being non-existent for the past 5 days

Fair: Wind moderate to fresh (13-24 mph). South or southwest.”

@lauraf13. . .try yours again to see if you are getting the Sager Fcst. What is the ICAO (Airport location) nearest your weather station. . .so I can check skyvector to see if there is an updated METAR obs.

Mines working now. KDFW or KDAL are the closest airports.

Will chock this up to a temporary (UNwelcomed) glitch in some sort of API -circle! Hope all of our stations stay up and the data continues to flow as it has been. . .uninterrupted.

This sounds like a glitch with the CheckWX API. Good to hear it is back up and running

So last week. . I sent a message to support @ CheckWX asking if they knew of any problems. This is the response I received. . .

Subject: Re: CheckWX API Contact Message

Thank you for contacting me.

There was an outage that effected all operations on This issue has been resolved.

I apologize for the inconvenience. Further details can be found at



Shortly after that. . .the “ERROR” problem for the Sager Fcst was alleviated. . .and the Sager Fcst once again appeared at the touch of a button. . .like nothing ever happened! But. . .starting back on the 4th (two days ago). . .the “ERROR” is back when touching the “Sager” button in the lower left corner of ‘wfpiconsole’.

Clicking on their status link (above) indicates. . .

…but. . . the “ERROR” still continues for the Sager Fcst.

just looked on mine, identical message to …
or an API overload or something else going way square… :face_with_spiral_eyes:

Thanks for the confirmaton @eric. Guess we’ll all have to wait till this gets “ironed out.”

Not much I can do here I’m afraid. This error is almost certainly an API fault. Interestingly I can’t access the checkwx domain at all at the moment….

Thanks for your confirmation / verification @peter. The problem is squarely at “CheckWX’s House!”

It would appear to me that the CheckWX API will never be fixed. . . so I eliminated the Sager button from my ‘wfpiiconsole’ :

Menu | Settings | Secondary Panels | Panel One | None.

Now…across the bottom…the only two visible buttons are “Moon” and “Lightning”.