Station Not Found

Hi everyone, I’ve had a Tempest for a while and just ran into Weatherflow PiConsole. I’m on my second clean install of Raspberry Pi OS on a 4B (first 64-bit then 32-bit), and I’m not sure what I am doing wrong. Any advice is much appreciated. Symptoms are the same through both installation processes just running the curl script on the github reposity and then wfpiconsole start. I’ve tried my tokens and a friends, but in no instance am I able to get past the loop of the bottom three lines. I tried googling the error and didn’t get too far. I tried manually editing the ini file and since I’ve never had a clean one, I can’t seem to get wfpiconsole to launch with manual edits.

  Please select your preferred connection type
    1) Websocket and REST API [default]
    2) UDP and REST API
    3) UDP only
    > 1

  Websocket and REST API selected

  API keys
  Please enter your WeatherFlow Access Token*:
    WeatherFlow Access Token cannot be empty. Please try again
  Please enter your WeatherFlow Access Token*: xxxxxxxxxxxxxxxx
  Please enter your CheckWX API Key*: xxxxxxxxxxxxxxxx

  Station and device IDs
  Please enter your Station ID*: yyyyyy
    Access not authorized. Please re-enter your WeatherFlow Personal Access Token*: xxxxxxxxxxxxxxxx
  Do you own a TEMPEST?* [y/n] y
  Please enter your TEMPEST device ID*: yyyyyy
    TEMPEST not found. Please re-enter your TEMPEST device ID*:
1 Like

Are you entering the proper Station ID and Device ID? You get these from the app by going to Settings, Stations, station name, Status. You should see a screen similar to this:

Thank you that was exactly it. Problem with reading comprehension!

1 Like