The Belchertown weewx skin

@eric - FYI, the Belchertown weewx skin has just un-seated the Android WF app on my wall-mounted tablet slash weather station console as the default display. If you set up a local or remote MQTT server, it will even display realtime weewx “loop” packets (think rapid_wind) as they arrive…


trying to get this to work, real mess

it seems to give anything as values (temp wise etc … not sure why)

1 Like

Did you set up MQTT? Without using MQTT, it can only display the weewx 5-minute archive data…not the instantaneous LOOP data.

Does it have a problem with metric???

1 Like

not even sure where the problem is, no mqtt (if the rest works I might start fiddling with it)

all kinda problems with skin, values … it all seems a complete mess
gives me 9.5°C when it is 2.1 etc … just changed skin … and values go pear square …
debugging debugging :wink:

1 Like

That skin seems to be very much ‘under development’ with a zillion thread comments on this if you look on the weewx-user google group, and you probably want to ask detailed stuff there with a far better problem description than ‘it all seems a complete mess’ and ‘values go pear square’ (whatever that means).

Skin installation on weewx normally is pretty straightforward. You run one command to install it. You optionally edit a config file if you want non-default units or fonts or features. But this particular skin might not be at that finalized/stable a state quite yet.

I can give it a try on a test pi tonight probably if you want another pair of eyes, but you’re going to need to provide a better description of ‘what you did’ and ‘what you tried to edit’ and ‘what you expect the result will be’ almost certainly.

I will post my working weewx.conf snippets when I get home from the salt mines tonight.

I did NOT set it up as the default skin, and it more or less worked out of the box. I did submit a few bug reports in github for documentation problems in the MQTT settings, but AKAIK they were already posted last weekend.

I’m not sharing the MQTT broker outside of my home network, but this is my live skin minus the live 2.5-second updates (Davis station):


don’t rush, reverted to the old skin and the temps is still about anything from who knows where … guess a clean install is not far away :rofl:
something broke and it will be a lot faster to re install from scratch. Also going for stretch, still jessie …


Use the standard skin and get that working first with whatever units you want to use. Only ‘then’ try to get fancy with more complicated skins. If you’ve mapped your sensors correctly in weewx.conf and are using @vreihen’s UDP driver, weewx will do the rest for certain. I’ve had my pi running that up for a couple months now. Rock solid and dead simple.

1 Like

Well did several things at the same time

Since I had to upgrade the wfpiconsole today and there is nothing else running on that pi, I decided to install weewx on the same pi. And it all works like a charm
And the skin is running ok this time. Not sure why it messed on the other install

Well I have now a spare pi again to fool :slight_smile: