UDP Broadcast Failure

Just got around to installing a station that was delivered last year… and it seems that the UDP Broadcast worked exactly once… and has not been working for the past few hours.

Tried power-cycling the HUB, but no go. Using a UDP sniffer on the network, but no go.


Station 3993
Hub 4769 (v105)

Uncertain - how exactly are you sniffing UDP ?

My udp listener can act like one if you need a python app that’s easy to use for a quick test. Works great on both python2 and python3, but you want to be python3.6 or later if you go python3. Just run it with the --raw option to see everything it hears on udp/50222

Right now, using an Android app. UDP Monitor.
Worked fine in my test (at my house) last year, but now that the Wx Station is live, I cannot see any UDP traffic.

if you have some computer, no way to use tcpdump in a terminal ??? Depending platform it’ll have other names but at least you can specify things like source p, ports, protocol etc

Not immediately. The station is installed at a remote location from me. I can log into the tablet I am using as a console, but cannot get to any Computer there.

Thought maybe @anon84912554 could check on their end to see if it is actually doing UDP as designed, or if there has been an issue.

You’d have to get a computer on the network that can actually sniff for UDP. Without knowing your network and software and address space and firewalls etc, we can’t help much more than that.

1 Like

Totally understand… This all worked when I initially set up the system. Now, a year later when it’s at it’s final destination, it no longer works.

maybe the local network is blocking that UDP port used by WF, can you test that remotely ? It is port 50222 if you ever forgot it :wink:

it sounds like you are no longer on the same network as the Hub.

Yup. Or if your tablet+hub ‘can’ talk, perhaps you are on a different ip range in the new location and you’re possibly sniffing for a particular ‘ip’ broadcasting to udp/50222 rather than ‘anything’ broadcasting to udp/50222. Or your router/etc. is blocking broadcasts. Something network related.

They are on the same network… I just set them both up on the same WiFi.

Trying to see if I can talk to the network guys about possible UDP blocks.

As mentioned before… wanted to see if @anon84912554 could verify the UDP broadcasts from their end somehow.

You set them up on the same Wi-Fi but yet one is remote? That is contradictory.

The location is remote from me… about 3 hours away… but the tablet & wx station are on the same network there.

Okay. So describe how you login to the tablet.

I am guessing it has public and private IP addresses.

So you have access to the router ?
Does it moved as well?
What is the WiFi IP config and what are the IPs of tablet and hub ?

Some access points have an isolation mode where the broadcast traffic is filtered out. Can you check the settings on the access point?