Rainfall Sensor Stopped Measuring Rain

I’ve had my Tempest for nearly 2-1/2 years and have had basically no issues. However, on 8/18 during a rainfall, I noticed it was not registering any precipitation. Looking more closely, I noticed my battery voltage had dropped below the level at which the Tempest shuts off recording precipitation (down to 2.3-something). My battery had never gotten close to being that low before, even during cloudy stretches in the winter here in Massachusetts. The battery level recovered into good territory soon enough and has stayed there, but we got around .25" of rain today and it never reported a rain reading and didn’t didn’t record any precipitation (this was a good steady rain, pretty hard at times). I turned the unit off and on but that made no difference. Strangely, when I looked at the two other WeatherFlow stations in my immediate area, they had also recorded no precipitation. If I look at other local stations on Weather Underground, they all recorded in the neighborhood of .25"-.30". I leave the NearCast setting turned on, but I turned it off in the middle of the rain to see if it made a difference and it did not. Until this week, I’ve never seen anything like this happen with the rain sensor. Any idea what else I could try?

1 Like

mine did this today and noticed during very heavy rain it was doing nothing, its 1 month old and battery is 2.66v

assuming im going to have to get the ladder out and up on the roof to reset sensor, wish theyd put that in the app already

I believe you can contact support and they can do it for you assuming it’s not fully offline?

Looking on the Facebook group alot of people reported this yesterday so must be something tempest side or a bad firmware update or something to affect a bunch of people the same time

Noticed the same thing on mine last night during a bad storm we were having in NC. Easily 1-2" of rain and the station recorded 0". All other functions are working, including the over 1200 lightning strikes that occurred during the storm.

I went through all of the reset/reboot procedures, however I took a look at other tempest stations in the area that were hit by the same storm, and they all registered 0" as well, so I think the problem is on Tempest’s end. I e-mailed support this morning so we’ll see what they say.

Interestingly, we had some very light rain this morning and it seems to be registering now.

Same here in Michigan. Worked perfectly for nearly 2 years and had a huge rain last night and didn’t register a drop

I just received this response from their support:

There was a service interruption yesterday that resulted in rain data not being sent back to the end-user. Our team was able to fix the issue early this morning. We apologize for the disruption! Thanks for your understanding.

I tried spraying water gently on it from the garden hose around 730am EST this morning to mimic a rain, and it was still not responding. Given they’re in CA, I wonder if that was before they implemented their fix. We’re supposed to get some more rain this weekend here, so i’ll keep an eye on it and see what happens.

My rainfall from yesterday is now showing up…worried about my battery, though.

If there is no rain expected in your area our filters will suppress the rain detection (this is part of the false rain system).
Look at your forecast for this.

Just checked, and mine did as well!

Ah, good to know! That explains why my test failed this morning. Thanks!

I am having the same issue with rainfall.
The last recorded rainfall was 2 weeks ago.
The local TV station is reporting 1" + today.
Any suggestions ?


I feel like I’ve had this issue last couple rains. Today we received a quarter inch but never got an alert for rain, and no trigger on IFTTT. I opened the app and saw it has measured rain, but no alert. Once I closed the app, saw the alert and had the ifttt trigger.