Request: Ability to manually force Power Saving Mode

Once again, in the cloudy short days of the north of Scotland, I’m having to bring in my Tempest to recharge it once every 20 days or so (there was no easy, safe way for me to leave the charger connected outdoors to my Tempest). Which is a pain, but tolerable, as it’s only for 2 months each year. However, it occurs to me that the power drain in Power Saving mode is much lower than when the unit’s fully charged, due to a lower sampling rate. Therefore if we had the option to tell the unit to use Power Saving mode EVEN WHEN fully charged, this would almost certainly enable my Tempest to get through the shorter days without needing a recharge. I mean the second-lowest power saving mode, where it’s still actively detecting rainfall. Would it be possible to enable this as a feature? The old SKY units had this feature in the app, after all.

I feel you, I just (and I mean the last few days) decided to get the power booster because of this.

There was supposed to be a firmware change that modified the power saving modes. I don’t know if it is done and what the extent of the roll out was.

The Power Booster Accessory will solve your issues. When the booster has batteries, the Tempest only charges from them when the voltage drops to ~2.45V so you don’t unnecessarily drain them.

I have a Power Booster, but the location of the Tempest is such that the Power Booster would have to be outdoors, too, and exposed to the elements (driving rain, high winds etc), and frankly the PB doesn’t physically seem ruggedised sufficiently to withstand prolonged winter conditions without water getting inside the battery compartment. Hence my periodically bringing the Tempest indoors to charge up for a few hours connected to the PB. My suggested change would obviate the very need for the PB.

Why not put copious amounts of the dielectric grease on all the contacts and try it? If you don’t think there is enough dielectric grease supplied, just get some more and add it. It is designed to be outdoors. Even the field test booster I have is still working and it isn’t as polished as the final product.

You could even attach the booster to charge and then remove it, leaving the cord but covering the connector until next use.


I was in Northern Scotland earlier in the year on Holiday. Very beautiful and lovely people as well. North Kessock was an especially wonderful surprise.

I was also concerned about my booster. I felt that the cover for it was not super solid given the amount of humidity etc… that we have in our bog so I bought a cheap waterproof junction box off of Amazon and mounted it like so…

It cost about 18 USD and so far has been pretty solid. I’d love to see Weatherflow provide a better box as an option long term. Hope that helps, I’m way too lazy to bring my device in periodically.

Hope that helps!



1 Like

I figure this is the most relevant recent post on the subject:

Is it intentional by design that when voltage drops to <2.15 (ish) that reading are every 2 hours or is it just that the unit is too low voltage due to drain and slowly recovers voltage and is able to get off one set of readings? Is this an undocumented ‘feature’ or just the wims of electrons?

I’ve already ordered the power booster, so this should not be an issue any more but I’m just curious.

What are the dimensions of the power booster, I have a about a week before mine gets here, but I can try to find an enclosure now.

Hi Glenn,

Here’s a link to the enclosure I purchased…

It’s 3.1 in wide and 7.1 in tall in the interior. The included cover on the power booster didn’t fit the interior of this. Probably I’d need another quarter inch interior width but you can see in the pic it fits almost perfect without that cover and I just looped a bit of tape over the batteries. I believe the booster is about 6 in tall so there’s some extra room in there for the cable etc…

This page shows the performance at different voltages…

Basically these ranges generate these frequencies of observation…

Mode 0: Voltage ≥ 2.455

  • All sensors enabled and operating at full performance

  • Wind sampling interval every 3 seconds

Mode 1: Voltage ≤ 2.415 from Mode 0 or ≥ 2.41 from Mode 2

  • Wind sampling interval set to 6 seconds

Mode 2: Voltage ≤ 2.39 from Mode 1 or ≥ 2.375 from Mode 3

  • Wind sampling interval set to one minute

Mode 3: Voltage ≤ 2.355

  • Wind sampling interval set to 5 minutes
  • All other sensors’ sampling interval set to 5 minutes
  • Haptic Rain sensor disabled from active listening

Based on the above I’d think your unit is just charging up above 2.35 once every two hours or so.

Best of luck!



Nope, this was between 0200 and 0800 when there was no sun at all. I get and log all the UDP traffic, so I know what the hub puts out; and I am making the assumption that the hub is relaying what the Tempest is sending. In between those 2 hours intervals, I received nothing from the Tempest.

I did not notice this behavior last year. I know there were changes to the Modes this past year and the documentation (in some places) got updated. I requested documentation updates before the firmware changes when I noticed that the behavior did not follow the posted modes (more of a clarification).

Thanks Glenn,

Thats fascinating. I could speculate about how the unit operates (maybe the battery wakes up every two hours to look for a change???) but it seems like something to put in front of the support team then.

Appreciate you sharing. I still get some oddball behavior from the websocket API when my unit goes offline for lack of sun.


This topic was automatically closed 540 days after the last reply. New replies are no longer allowed.