WeatherflowUDPinstall issues

Does anyone have an actual working weewx station on weatherflow?

I not a linux newbie or an linux expert, I have followed the instructions posted by the letter, I have weewx configured, But cannot get the weatherflow udp to install and load, I’m using a Raspberry Pi 3 B+,
I loaded using PIP and everything loaded and was able to configure it as a Simulator and it displays fine on html,
Ive tried captain-coredump and another forked version that I found on github…Both seem to be identical??

Are there steps left out on the instructions? or is there a better way?

Any help would be appreciated

umj

Yes, many dozen people. Currently there are 77 registered stations on the weewx map running it (and registration is optional so the true number is likely much higher).

What version of weewx ? What did you do ? What did you see as output ? What instructions are you referring to ?

[…for the rest of this, I’m assuming you are running v5 beta since you mentioned pip…]

v5 replaces the old wee_whatever commands and puts everything within an integrated weectl command, so to install a driver/extension/skin…

  • for v4 and earlier it is wee_extension install
  • for v5 it is weectl extension install

If you’re running a pip v5 installation, activate your python virtual environment and you can simply install it via:

  • weectl extension install https://github.com/captain-coredump/weatherflow-udp/archive/refs/heads/master.zip

and check it installed with

  • weectl extension list

Note that you will still have to edit the weewx.conf file to add the sensor_map from the example at https://github.com/captain-coredump/weatherflow-udp/blob/master/sample_Tempest_sensor_map to your WeatherFlowUDP driver section and be sure to edit those lines to put in your Tempest ID to replace the example ones.

then set weewx to use the newly installed driver via:

  • weectl station modify

(and pick the WF driver which is likely first in the list of available choices when it prompts you)

That sets you up to use the WF driver. Run ‘weewxd’ to see if it works interactively. You should see data if you did the above correctly. Control-C to exit weewxd. Then start it with systemctl like any other process and you’re done.

oh - I’d suggest you delete your archive and public_html trees from the simulator before calling it good so that you don’t have any bogus simulated data…

1 Like

Hi Vince

Thank you for the reply, I already have weewx installed, The problem I’m having is getting the .zip download to install on my raspberry pi , using the instructions provided by captain-core dump.

I’ve already looked over the the config file and it all looks straight forward, I have other weather stations , APRS digipeaters and telemetry broadcast stations running.

The udp drivers at this point seems to be the hold up,

Thank You for your Help

Rick

Vince

I forgot to mention this is a fresh install of V5 beta and I have already ran ran weewxd and saw my simultor data and can also see it on my browser,
I should be good once I can get the udp broadcast from the WF hub to the weewx program.

Will I need to provide any port forwarding between the hub and the Pi 3? I havent seen any information on which udp ports being used?

RIck

You’re going to need to explain what “The problem I’m having is getting the .zip download to install on my raspberry pi” means.

Does ‘weectl extension list’ show that the driver is installed ?

Vince

Thee weeclt cannot be found and neither can the weectl extension list

It should have installed from the weewx v5 pip install, The process was followed to the letter!

Any suggestions?

Thanks Rick

Yeah - please learn how to submit a problem report. WHICH process did you follow ? Lets see your transcript from the console to see what you did ‘exactly’ and what the output was. What errors do you get ?

In the absence of any more info from your skeletal description, I’m going to suggest that you try “source ~/weewx-venv/bin/activate” to activate your python virtual environment so the shell can find the weectl command therein. You need to always do that in v5 pip installations now.

Hi Vince

I have it working by using multiple sources of information, to get it working in the way I was wanting, It’s a shame there’s isn’t a complete step by step for users That have limited experiencing in interfacing the Tempest to other mediums. When I’m finished I’ll pull my notes and submit it to the community and post it on one of my cloud storage sites, It seems there were many dead end links that left a lot of critical information missing.

Thanks again for your help.

Rick Nicholson

First of all, v5 is a BETA so it is unreasonable to expect people with legacy docs out there have caught up to the breaking changes in v5’s new pip installation method…but there are docs that come with v5 that do work fine as written.

A recent but not necessarily 100% current set of docs is at WeeWX 5.0

Although there are many people running v5 beta, we cannot read your mind. What in particular are you confused about ? Installing weewx ? Switching to the WeatherflowUDP driver ? Something else ?

Hi Vince

The legacy information in the forums has been the issue , There seemed to be broken leaks on information, I used the WeeWx 5.0 and loaded easily, The weatherflow UDP was the issue, But found it was firewall issue within my network, after creating a new firewall rule for the device, all is good…My next step is to add a couple of plug ins to add it to APRS rf… weewx -aprs, direwolf and aprs-send-weather…

I have 6 peet Bros. wx stations running in Indiana and I’m looking at replacing them due to age and expense with Tempest wx stns,

All of the sites now have either fiber of a wisp backbone feed to the sites for our multi-mode digital voice modems and linked digital repeater system, I’m wanting to use our updated infrastructure to update the weather stations that have been plugging away for10 years, Since they were all hardwired and running on serial output , The hardware has been breaking down and unfortunately Peet. Bros.hasn’t changed much and the cost doesn’t justify the product.
Any tips on integrating weewx-aprs or aprx into WeeWX 5.0 would be appreciated.

Rick

n9umj

ok - so you have general weewx questions that have nothing to do with the weatherflowUDP driver or with WF gear in general.

Bottom line - you’re asking in the wrong place.

If you have general weewx questions you need to ask in the weewx-user google group or perhaps wxforum.net as a secondary location to look around in.

There should be no differences in v5 regarding integrating stuff into the new version, plus/minus v5 beta bugs of course.

Vince
The problem was with the weatherflow dup drivers, The information on how to install the drivers on the forums were not correct or the links were not available most of them had a 404 not found.

I dug around until I found good information outside of the forum

Thanks again for your response

Rick have you pulled your notes together and submitted to the community? Limited experience here with Weewx and Weatherflow etc.

Regards,

Bob Furlong

@robertj.furlong - rik complained but really provided no details, so nobody can help in that situation.

Many dozen folks have done this successfully. There are currently 90 sites who chose to do optional registration of their weewx setups using this driver, so there have to be well over 100 actual users.

Do you have particular questions ? What hardware are you trying to install on ?

Have you figured out how to install weewx and run its simulator driver so you can get your feet wet ?

This is a 10-minute job typically at worst.

v5 weewx just dropped over the weekend so these are the commands literally cut+pasted from their quickstart docs. This gets you a vanilla Simulator system running.

I might add that you should probably run over the 32bit raspios if possible. You can check your system via:

sudo dpkg --print-architecture

INSTALL WEEWX

sudo apt install -y wget gnupg

wget -qO - https://weewx.com/keys.html \
   | sudo gpg --dearmor --output /etc/apt/trusted.gpg.d/weewx.gpg

echo "deb [arch=all] https://weewx.com/apt/python3 buster main" \
  |  sudo tee /etc/apt/sources.list.d/weewx.list

sudo apt update

sudo apt install weewx

# (just hit return when prompted)

INSTALL THE DRIVER

Next install the weatherflowUDP driver. The commands in v5 weewx have changed since the driver was released years ago. The following uses a fork I created that populates a default sensor map into weewx.conf for you so you don’t have to cut+paste…

This does a git clone of my repo and checks out the branch with my installer patch therein.

sudo apt-get install -y git
cd
git clone https://github.com/vinceskahan/weatherflow-udp
cd weatherflow-udp
git checkout install_example_sensor_map
sudo weectl extension install .
# (hit return when prompted)

CONFIGURE THE DRIVER

At this point, you have the driver installed, but not enabled. Edit weewx.conf and change the example
ST-00000025 values in the [[sensor_map]] at the bottom of weewx.conf to match your sensor id so the driver will listen for ‘your’ Tempest rather than the ‘example’ sensor id.

ENABLE THE DRIVER

sudo weectl station reconfigure
# (enter your description,altitude,lat/lon,units if you want)
# (choose the number next to the WeatherFlowUDP driver
#     which is likely 0 to enable that)

RESTART WEEWX

sudo systemctl stop weewx           ### so we can clean out the simulated data
sudo rm /var/lib/weewx/weewx.sdb    ### delete the old Simulator database
sudo systemctl start weewx          ### restart weewx using the WeatherFlowUDP driver

At this point you’re running with the WeatherFlowUDP driver and you should have it successfully listening to, and hearing, the Tempest data. You might want to edit /etc/weewx/weewx.conf to set debug=1 at least temporarily to have it log more verbosely until you’re happy it’s working. Remember to restart weewx after editing weewx.conf

TO CHECK YOUR LOGS

Modern debian os use systemctl to log so the commands can be difficult to figure out. This should work…

sudo journalctl -xe -f -u weewx
# (hit control-C to exit)
1 Like

@vreihen you might want to consider merging my (PR#27) so new users get the pre-populated weewx.conf stanza automatically.

Seems like many people either don’t copy+paste from your README file nor edit their sensor id into place for some reason. This PR makes it as obvious as possible.

I bumped the ver to 1.10.1 since it’s not really a functionality change in the very stable driver itself.

I don’t want to get folks used to installing my forked version if that can be avoided, so I’ll edit the instructions above accordingly if you can get around to merging the PR. Thanks again for a fabulous driver. So stable !!!

Have been using the WeatherflowUDP driver install from https://github.com/captain-coredump/weatherflow-udp/archive/master.zip for years.
Never had any problems with it.
Now with the update of weewx to version 5.x, the rain values are no longer correct.
In weewx use the METRICWX format.
Now I have rain amounts that are twice as much as with the original WeatherFlow Tempest station.
What am I doing wrong or am I adjusting this in Weewx?

Have you tried downloading/installing a fresh copy of the station driver? @vinceskahan provided several fixes for WeeWX V5.x issues, and they were merged into the master branch last Sunday…

@vreihen - there were no changes in the recent updates I made to your driver that would affect any math. All I did was fix the station registration issue v5 caused, as well as dropping in a fully specified stanza into weewx.conf for new installations of the driver.

@mother79 - to reiterate what I said over in the google group for weewx…

https://community.tempest.earth is the right place for this one probably.

You will need to compare your UDP totals with what WeatherFlow displays
via their REST or Websockets interfaces.  Make sure you have RainCheck
(or whatever they call it now) disabled so that their servers report the
same thing as what your UDP messages indicate.   The totals should match.

How to do this comparison is something other folks have asked on the
WeatherFlow forums and it can be a little complicated, but if you ask 
'there' you will certainly get some answers for how to do this.

So please do the comparison to verify your station totals on WF servers are correct…

(apologies for any crazy reformatting of the quote above that WF’s awful forums software did)

1 Like