HUB Went offline

This morning at 7:15 my weather station (1565) went off line. I have no idea what happened - my WiFi was fine at the time and there didn’t seem to be any issues. Naturally it happened when I was at work so I had to wait to reboot when I came home. After unplugging the HUB and waiting 30 seconds I plugged it back it and now it seems to be working again. Anyone else have something like this happen to them?

Thanks for the report nels. We upgraded the wifi firmware blob on your hub, that should help with the lockup.


1 Like

Oh nice coinciedence …
I had a similar one yesterday evening (CEST) (what’s about your time zone ?):
One of my two side by side installed hubs showed a green status while the second one showed a red status. As Inwas not able to care directly, after a couple of minutes, both showed green, without any manual intervention.
Amy ideas @rderr?

Yesterday, Thursday (20th), at around 12:30 PM PST (Pacific standard time) my hub stopped (station ID 4809).

I do not know what happened nor why the hub just stopped - the LED was blue - I had neither my phone nor my tablet on at the time. None of the other devices connected to the router were affected (all my IoT, smart devices and smart hubs are all connected to one specific router).

It was only about 8 hours later that I realized the hub had stopped when I looked at my WeatherFlow data page and saw the red indicator in front of the ‘Offline’ word. I disconnected the power supply from the hub and waited about 10 minutes. I then power up the hub - the LED was red for a second and then changed to blue. Still, the hub remained stopped (offline).

After trying trying the power on/off cycle four times, I decided to reset the hub by pressing the reset button at the back. Finally, the LED at the back of the hub remained red for a few seconds and then changed to green.

The hub has been back online for about 6 hours - no additional stoppage since then.

The blue led lockup is a known issue. We have a fix in place for the next version of the firmware. I’ve upgraded Ray’s hub to the v95 to test the fix. Please write if you get the same lockup again.


1 Like


We may have been in the process of upgrading your hub’s wifi firmware blob or the hub may have lost its connection to our servers.


I just checked the hub status and the hub firmware revision is still 94 - it is firmware revision 20 for the AIR and firmware revision 43 for the SKY.

I have first rebooted the hub (removing the power); when I saw the firmware revision was still at 94, I pressed on the reset button at the back.

Still at firmware revision 94 - station ID 4809.

I just checked our systems and I’m sure you’re at v95 now. Your app may have the value cached.


1 Like

It looks like there had been a rush on hub issues. Support had to upgrade the software on my hub as well. I’ll find out for sure this weekend if all is good as I normally see drops when it storms. Lots of storms predicted for North Texas this weekend.

It seems that the hub has, once again, stopped - according to the status screen, this morning at 05:18 PST.

The LED (at the back of the hub) is still blue.

I have just checked on the hub and I have not yet re-started the hub (at 18:15 PST) - I will not be able to restart the hub until later (after 20:00 PST) as I will be out of the home/office for the next hours.

Unfortunately, for some reasons, over the past two days, the hub has become unreliable as it has stopped for two consecutive days… :disappointed:

Did the HUB go off line on the WiFi side or did it stop accepting connections from SKY and AIR? I ask because at 19:59 Pacific time both SKY and AIR recorded their last reading before going off line. I didn’t notice it until about 1h 45min later. I had received two messages on my phone:
I went and looked at the hub and it had a blue light on (5080) where the hub for my other station (5075) right next to it still had a green light. I opened the Smart Weather app and noted that the light on 5075 turned blue as expected. When I exited the app, only 5075’s led turned green again. I noted that in the station status that the device_online_count was 0 and the device_offline_count was 2. Unplugging the hub for a few seconds and powering it back up brought it back on line at 21:46 Pacific time. Here is a screen shot of the status screen.
Hopefully it gives @rderr some insight into the issue and if it is the same issue as other’s HUB’s blue light specials.


1 Like

The blue light on the hub is because you are communicating with the hub via Bluetooth. Or is that irrelevant?

That is irrelevant because I was not connected with bluetooth to it. The blue light was on anyway. Connecting with bluetooth and then disconnecting didn’t change the light on that hub, only on the other one beside it that was still talking with its paired SKY and AIR worked normally. That is why I included the behavior of both hubs in my post.

1 Like

As discussed in an other thread… sometimes the Hub seems to stuck after disconnect / within a Bluetooth connection and hangs up.
So not totally irrelevant, but not the key to focus on.


The hub just stopped - there was no connection to the Wifi, no access to/from the Internet - the hub even disappeared from the router’s network map.

Before I disconnected the power supply from the hub (at around 00:30 AM on September 22), the LED at the back of the hub was still blue.

Note: Neither the ‘Weather Display’ software nor the ‘Weather34 Home Weather Station Dashboard Template’ have been providing up-to-date weather data.

The last connection/communication via my tablet was through the WiFi at around 02:45 (that is AM on September 21) - I do think the tablet was connecting/communicating via Bluetooth. Afterward, the tablet was switched off.

Further connections/communications to either the hub or to the WeatherFlow API were through my Firefox browser.

According to the (online browser’s) status screen:

  • Hub: Last State Changed @ 2018-09-21 6:20:11 AM / Last Status Time @ 2018-09-21 5:18:07 AM / Last Hub Time @ 2018-09-21 5:18:05 AM

  • AIR: Last Observation (via app) @ 2018-09-21 2:41:51 AM / Last Observation (via Hub) @ 2018-09-21 5:16:48 AM / Last Observation @ 2018-09-21 5:16:45 AM / Last Status Time @ 2018-09-21 5:16:48 AM / Last Hub Time @ 2018-09-21 5:16:45 AM / Last State Changed @ 2018-09-21 6:20:11 AM

  • SKY: Last Observation (via app) @ 2018-09-21 2:42:20 AM / Last Observation (via Hub) @ 2018-09-21 5:17:17 AM / Last Observation @ 2018-09-21 5:17:15 AM / Last Status Time @ 2018-09-21 5:17:17 AM / Last Hub Time @ 2018-09-21 5:17:15 AM / Last State Changed @ 2018-09-21 6:20:11 AM

The hub stoppages (or crashes or disconnections) seem to have started after the firmware update 94 - it might just be a coincidence…

The hub, although not at its current location, had been operating without any stoppages since its arrival at my home/office, on August 23, 2018.

Another coincidence, maybe, I think both stoppages were following some light showers…

The hub is located at about 1.5 meters (5 feet) from the router. The router is a Cisco/Linksys WRT1900AC AC1900 Dual-Band Smart Wi-Fi Wireless Router


I think the problem is known but not sure the fix is ready

but let’s be logical, when the led is blue, means the hub for some reason went into to BLE mode so it is not sending any data via wifi anymore, I think it is coded that way. When a phone is indeed linked via BLE, it is your phone playing relay/modem to the internet, hence providing data to the servers etc

Now if the hub goes in BLE (as a bug) and there is no phone linked … it sits and sends data via BLE into the abyss of nothing …

now WF is there a fix already ???


Where did you get the info that the phone relays data when it is BLE connected to the Hub???

1 Like

just test and you’ll see it does, when I do my iPhone is nice enough to relay … or at least it did in the past. Didn’t try recently

also when one of us can’t update the hub firmware, WF asks to link in BLE so it can try via that link instead the router …

from the faq


Oops! Bad news.

The hub cannot be seen by neither my phone nor my tablet!

I first tried to disconnect/wait about 10 minutes/reconnect the power supply - no connection!

I then disconnected/waited about 10 minutes/reconnected the power supply and pressed on the reset button at the back of the hub - no connection!

I have tried the above two procedures using a different power supply - still, no connection!

The LED might be blue (at the back of the hub), but the hub cannot be seen by the router - even my version of the MyLanViewer software cannot find the hub!

Please, assistance is now badly required…

not sure we will able to help much more then what you already did
did you rename your wifi networks or are there several with the same name by any chance. Or a guest network ?

if same naming for the 2.4 and/or 5 g network, change them to be different
if a guest network, try disabling it


support via the website :

support via mail :

Hopefully someone is behind the helpdesk to help you out

1 Like