Hub offline after power outage

Evening - I’m away from home at the moment but noticed our power went off for 4 minutes today and WF is not reporting via its app:

I assume the hub has not come back online - although i am getting data via udp so thought i would post.

This has happened a few times - i thought the hub was meant to come back online in case of a short power outage?


That is strange. The Hub is online but not connected to the WeatherFlow servers. Send an email to and ask the tech to investigate.

Thanks - i have bounced a email to support…


Hi Andy,

That’s very interesting. Can you tell me if you’re getting the hub_status UDP message when your hub went offline?


I gave it a power cycle when i got home and it came back - so apologies but i now cant check, all i know is that my rapid wind data was reporting fine (although still not sure i am getting the 3 sec updates).


Thanks for the information.

The three second data was probably coming over the bluetooth connection to the hub. Was the LED on the hub RED?


Yep the light was red - it was transmitting to my Raspberry Pi the other side of the house (which has not been paired with the hub) so I’m assuming it was via wifi (?).


I have a Raspberry Pi setup as an access point with a WiFi uplink for my mobile unit. I noticed that the hub light goes red when the uplink is lost yet the RPi is still getting the data from the hub. This means the hub light goes red for any broken link with WF servers.


David @dsj would need to confirm but I think that is correct. If the Hub has an internet connection but cannot cannot connect to the WeatherFlow server the LED is red.

Correct, that’s the expected behavior.

Thats good to know - thanks for all the answers - thought if it had wifi it would connect to the servers but it needed a power cycle.

No worries - spent the last few hours trying to solve my sky stuck in power save mode but without any joy (thats a separate thread :slight_smile: )


The hub does try to connect to our servers when it has wifi. It tries about every 10 seconds as long as it’s not connected. We know the hub is trying to reconnect, but we’re not sure why it’s not working correctly. We’re enabling additional status monitoring which should tell us where it’s failing in the process.



Hi All WF’s,
Every time there is a mains power interruption here the hub goes RED and stops sending data.
The only remedy appears to pull the micro USB, wait, then replug - it then show GREEN as it reboots.

Fine if I’m around, but there have been interruptions when I’m not at home.
Any suggestions to guarantee an uninterrupted data stream gratefully received…

And yes, if I use my cel to access your app,
the hub turns BLUE…

Maybe you put a power bank in between your power supply and the Hub hence you get an UPS?

It seems like you have a Wi-Fi issue with the access point you use. Tell us what Wi-Fi equipment you use.

1 Like

Currently an Apple Airport Time Capsule, but soon to be replaced by Google Mesh…

FWIW, mine has worked fine with the final version of the Apple Airport since day one. Let me throw in a footnote that I’m running separate SSIDs for 2.4 Ghz and 5 Ghz radios in the Airport…

Did you name the 2.4 and 5 GHz the same ssid name?

Hi there. This is a rare and pesky issue that we’ve been trying to solve. And you can help!

We’ve just enabled a network debugging feature for your station. This feature allows us to collect diagnostic info via the iOS app, over BLE. Next time you experience this issue, please try these steps:

  1. Confirm the light on your Hub is RED but do not cycle the power
  2. Open the Smart Weather app on your iOS device and confirm the light on your Hub turns BLUE to indicate a BLE connection is active.
  3. Let it stay connected for a brief period (it usually takes seconds, but I’d give it a minute or two)

That’s it! Go ahead and restart your Hub to restore the connection. Then send an email to and let us know the approximate time you performed the above steps. Hopefully the debug info will give us some info about what’s going on.