How to set up Tempest with Google Mesh wifi system

My new tempest arrived yesterday, but I’ve been unable to set it up. The hub recognizes my networks, but regardless of my efforts, it won’t link up when I enter the password for the network. In doing research there’s a note that says may have problems setting up with mesh wifi. I’ve tried shutting everything off and only starting one mesh pod and no luck. Suggestions???

Thanks to everyone, our Tempest is online!

Hello lruf,
below a few advices learnt from past problems that might help

disable the 5G network till it is correctly setup via the 2.4G network
also see to it that both networks don’t use the exact same name
don’t use weird characters in password like §<% etc, sometimes that messes

Hope with this it works


I’m no expert, but I have read that devices which work on 2.4GHz, don’t like to “see” 5GHz signals when they’re connecting. Is there any way for you to temporarily turn off the 5GHz signal on your mesh while you’re setting up?

I have mine set up on the Google mesh and didn’t have that connection issue. I also don’t recall ever having to disable the 5G network. I’m not even sure I know how to do that. :wink:

Thank you everyone! Your suggestions worked! We’re online!

1 Like

for those who look this up later, what exactly did you do that worked ?

1 Like

lol, Vince, I’ve never been one to do one step at a time and I did it all. I made sure there was a separate 2.4ghz network that was set up, made sure only one Google wifi was on, and made sure I didn’t have any “weird characters” in the password (thanks to Eric). I don’t know if it was one specific thing, or a combination, but thanks to y’all and Tempest, I’m a very happy camper!