Tempest - Issues setting up new Hub

The off the chart excitement on getting the tempest today was quickly quelled by my incapability to get the HUB set up and working.

What I tried :

  • Unplug Power from Hub and restart - Many times no help
  • Hard reset HUB via the reset button - Many times no help
  • Use another phone - Used three - No Help (All Android)
  • Reset Router - Twice no help
  • Reinstall Tempest App - No help

The hub shows a red light, when I hard reset it blinks green for a few seconds then red again, I can manually connect from my phone(s) to the HUB, and it turns blue, but the app does not know what to do with this.

On the app it always fails on the “Checking Hub Connection” step.

One thing to add - I used to have a hub before with the Air / Sky setup, which fell victim to my wife claiming its electro junk and throwing it out.

Maybe somewhere the app tries to connect to the old hub?

I am out of ideas. Any help?

first idea coming to mind, can the hub connect to the Weatherflow servers via your wifi network?

here is a detailed setup page, might help

Thanks - followed all this.
I dont even get that far, within the app it never connects, so I cant set up my tempest and thus have no idea what the hub does or doesnt know.

Is this your first station or do you have a Sky / Air station?

I used to have Sky + Air + Hub. They all got axed by my wife by accident.

Tried using my old account - No dice.
Tried setting up a new account - No dice.

I cant get the app to connect to the HUB.

Is the old Hub still online?

Not that I am aware of, its been carried away by the garbage man. Assuming no one grabbed it and uses it.

Ouch. That is not nice but we won’t get into that.

Plug in the Hub and the LED should be steady Red.

Open the application and tell me what it shows.

My suggestion would be temporarily turn off your 5Ghz network. After you get the blue light for the bluetooth connection it should be able to find your 2.4Ghz network.

1 Like

@GaryFunk - “Checking hub connection” for a few seconds, then “Hub not connected”

@sunny - Ill give this a try

1 Like

@sunny - didnt work.
My babysitter uses an iPhone, but she cant remember her apple id password, so this hub is still mocking me mercilessly with its red light.

last idea and if this fails, please open a ticket with support (top menu)
eventually linking to this topic so they see what you already tried

Bluetooth Connection Issues

Hub not found

If you are getting a “Hub not found” error message, first make sure the app has permission to use Bluetooth on your device.

For Android devices: Enable Location Services.
Enabling location services is necessary to scan for Bluetooth LE devices.
For iOS devices running new iOS 13: Following the new iOS 13 update, Bluetooth permission may have been disabled. Make sure the app is allowed Bluetooth permission. Go to Settings > scroll down and find the “Smart Weather” app and enable “Bluetooth Sharing” for the app.

  1. Restart your smart phone or tablet.
  2. Unplug the Hub for a moment to power cycle the device.
  3. Enable Bluetooth on your smart phone or tablet and stand close to the Hub.
  4. Open the app and wait for the blue LED to illuminate on the back of the Hub.
  5. Proceed with station setup in the app.

just to be sure, when you disabled the 5Ghz network on your router, did you connect your phone to the 2.4 Ghz? and then the bluetooth connection to your hub?

Yes. Disable 5g. Connect phone to 2.4g, try to connect to hub - Same result. It doesnt establis a bluetooth connection to the hub.
Was worth a try, but didnt solve it.

hmm but you said the blue light went on in the first post. that indicates it did establish the bluetooth connection. I’m confused.

and just to be sure, for bluetooth to connect on android you need to have your gps running.

I can manually connect to the Hub by selecting it from available devices in bluetooth pairing.
Thats when the led turns blue.

I tried the pairing in the app with this connection established and without, same result.

The app doesnt connect itself, never seen the red light turn to blue this way.

Hub connects fine to both bluetooth and WIFI. When I try to add Tempest sensors, green light blinks on sensor continuously. App eventually times out and says “no sensors found” or something to that effect. I’ve reset the hub twice, still not working.

I don’t have a tempest, but on the old units, the green blinking led was also a reset button. hold it down a few seconds.

Got it working now.

unplugged the hub for a few minutes.

Plugged back in and held down reset button with small pin until light turned off and then red.

Removed old hub connection to IOS device.

Reset sensor by holding down green blinking button, as suggested.

Everything working now. Not sure which steps were the ones really needed (prolly sensor reset). Either way. It worked. They need to include how to reset sensor in the instructions.

1 Like