Hub can't connect to Wi-Fi

My Hub lost connection to Wifi. It has a Red LED, but changes to Blue when connected to Bluetooth. I can see the routher in WiFI setup but conenction fails with error 1024.

I have reset the router, reset the Hub, created a guest network, confirmed broadcast on 2.4ghz. Nothing works

Firmware is version 98

Any thoughts?

Move the Hub close to the Wi-Fi access point and try it again.

thanks it is pretty close. I can see it in the app (it just refuses to connect)

do a search for ‘error 1024’

thanks, I tried all the things related to that error ( unless I missed something in my post??)

Send an email to and reference this topic. Hopefully someone can fix the issue

Cheers. I’ll try that, Thanks for responsing

I have the same problem. Any solution?

if you’re using weird characters in SSID like @%*- , ditch them as in the past it seemed to block for some users

Hope this helps solve the problem

1 Like

Thanks but it did not help. The strage thing is that it worked fine until last week.

did you try resetting the hub ?

ehre are the steps :

Hard to say, I found a very small hole that I stuck a needle in but I got no indication that the hub was reset by the app or hub itself.

can you connect if you create a hotspot using your mobile phone? If so, try resetting your router as well

@maxtillberg how close is your Hub to the router? It looks like you’re getting a fairly weak signal between the two.
First, try moving the Hub closer to your router.
You may need to reconnect to WiFi: Power cycle the Hub (unplug for 10 seconds and then reapply power). Enable Bluetooth and open the Smart Weather app. Wait for the blue LED on the back of the Hub then go to Settings > Stations > (choose your station) > WiFi Setup > follow the steps to connect to WiFi.

If you need additional assistance please let us know, you can submit a request here:

A post was split to a new topic: Hub’s WiFi & Bluetooth connection

By changing network to an extremly old router and using an android phone I managed to connect the hub. Strange.

I was struggling with this recently and I just realized today that the problem started after switching my router to use WPA3/AES in the security settings. I set up a separate SSID with WPA2/Auto and the hub was able to connect again.