Hardware received but hub won't connect to BLE (solved with iPhone)

Received my hardware but I can’t get the hub to connect to BLE. It appears if I do a Bluetooth scan on my Samsung tablet, but does not appear on my Verizon Droid phone. LED is solid red after 10 secs or so when I plug it in (presumably it’s booting). I also tried multiple power adapters.

App displays “Hub not connected - make sure HUB has power and is within 10 feet. You may need to restart the app, or cycle the power on the HUB” (I’ve done both multiple times, trying both mobile devices with the current version of the app installed on each).

Ideas ?

First, don’t scan for the Hub on your Phone or Tablet.

Use the WeatherFlow Application to connect to the Hub by entering the serial number in the application.


Yup - did that. Entered my site name and it got the correct location info from the phone (lat/lon/altitude). The system is registered on the website https://smartweather.weatherflow.com/station/4677/list but I can’t get to the part where it tries to set up wifi… Get the ‘Hub not connected’ no matter what I do or how many times I restart the app, the phone or tablet, or the hub.

Do you not see this?


It may be best to reset all devices and start over.

I think I number-dyslexia’d the station id in the mobile app and entered the wrong hub id perhaps, but the serial number on the website shows the last 4 digits matching the correct hub id.

Is there a way to clear whatever is saved someplace completely ? I uninstalled/reinstalled the app but don’t get the initial questions so there’s something saved ‘somewhere’ (guessing on a WF profile).

I can’t get to the ‘delete station’ screen on the WF app to delete the station to try to start over
(grrrrr…if the mobile app is blocking me, why can’t I use the web to do this?).

In the Application, delete the Air and Sky. Then delete the station.

Press the Gear icon in the upper left corner. Then press Stations, press the Station. Press Manage Devices, Left swipe each device to delete it. Then return to Stations and left swipe the station to delete it.

Next, reset the Air and Sky by pressing and holding the button (where the LED is) for 5 seconds. Then insert a paper clip to reset the Hub in the small hole above the LED on the Hub.


I can’t get to that screen - it continually goes to ‘Add Device’ and when I hit ‘next’ it fails to connect to the hub. Trying the paper clip reset thing, it blinks green for a few seconds then goes solid red again. No joy in the app.

FWIW, I do not recall ever seeing it go green when I plugged it in the first time, the LED went straight to solid red (I think).

Then delete the devices in the application and reset each device.

Sorry to be dense here, but I can’t get to any screen in the app to even attempt to delete any devices.

The app goes immediately into the ‘add device’ screen. I have a ‘next’ button (where it fails to connect to the hub) and a ‘sign out’ button (tried that multiple times), and a back arrow that jumps clear out of the app.

Clear the memory on the application and restart it.

Thank you for the left-swipe to delete them. That at least worked…

I re-re-re-re-re-added the device and the web status shows the serial number and firmware version (72) with a different station id 4684 but I’m still getting hub not connected and the light is solid red.

Other than trying it again with the tablet and then with the Mrs’ ipad/iphone tonight when she gets back, I’m at a loss here.

Did you get to the part where it asks you to enter the Wi-Fi password?

nope - it can’t connect to the hub which seems to be a prerequisite

Did you to a hardware reset on the Hub?

5+ times, and 10+ times tried a power reset, and tried 3 different usb chargers, and tried logging out+in of the app multiple times, and deleted/reinstalled the app on both phone+tablet, and rebooted both phone+tablet multiple times. No joy.

A reset button blinks green 5x then goes solid red after maybe 5 seconds. Yanking the power from the hub has it dark for those 5 seconds then goes solid red. Dunno if that matters.

Did you rest the Hub using a paperclip to press the reset button on the Hub?

as I indicated above, yes - perhaps 10 times so far

You only indicated you removed the power from the Hub.

I suggest you email support@weatherflow.com

yes, I removed power multiple times from all three devices, reset/rebooted/power-cycled my phone, reset/rebooted/power-cycled my samsung tablet. Also tried my wife’s ipad. No joy whatever I try.

One time after resetting with the paperclip the hub went solid green but it still was non-responsive. Reset it again and got the same 5-blinks green then solid red light.

Thanks for the tries (plural) regardless !

I don’t know what the issue can be. If you followed the instructions in the order I gave you it should just work.

Hopefully WeatherFlow can get you set up.