Unable to pair Tempest sensor device to hub

I was very excited to receive my WeatherFlow Tempest. Unfortunately my excitement was short lived when I was unable to pair the Sensor device with the Hub. I e-mailed support the other day but haven’t heard back. While I wait I am wondering if anyone has seen this problem and/or has ideas on things I can try.

What happens:

  • I am able to connect to the Hub from the Android app as the Hub light changes from red to blue.
  • When prompted I turn on the Sensor switch and the bottom light on the Sensor slowly blinks green.
  • I hit “Next” in the app which then says to wait while the sensor device is found.
  • The Hub light beings blinking blue and light blue.
  • After some period of time the search times out, the App goes back to telling me to power on the Sensor.
  • The light on the bottom of the Sensor does not change during this whole process.

What I’ve tried:

  • Resetting the Hub by holding the reset button when plugging the hub in until the light turns blue (found via radio reset topic.)
  • Resetting the Sensor by holding the clear button until the light flashes green quickly then goes back to slowly blinking green (as recommended by troubleshooting guide.)
  • Pairing the devices in different locations in my house in case there’s some weird interference going on.
  • Pairing the devices next to each other (~1 ft) and further apart (~6 ft).
  • Restarting my phone.

Has anyone else seen this problem? Does anyone have ideas on other things I can try while I wait on support?

The light changing from RED to blue means that the hub has no connection to the WeatherFlow servers via WiFi. This is one thing to get fixed. Go into the app to Settings, Stations, station name, WiFi Setup to get this part setup. Once this is done you shouldn’t have to reset the hub again.

Some other things to try:

  • Uninstall the app and re-install it. Your settings are stored in the cloud so just log back in with the same account credentials and everything will be there.
  • Try another mobile device, even if it is just temporary. I know this sounds strange but I have experienced situations where my Android device would “see” different sensors than my iOS device. I don’t understand why but it was handy having both platforms to test.


Did you manage to resolve this issue eventually? I’ve just received my Tempest and have the some trouble :frowning: I tried everything what you described with no success (resetting, different mobile devices - iPad, Android phone …).

try again now, should work. Let us know if all is ok please.

Thanks. I let the hub switched on which resulted in firmware upgrade. Then pairing worked like a charm.