Tempest won't connect to the Hub

After the Weatherflow server went down yesterday (9/23/2023) My tempest will no longer connect to the Hub. I’ve tried all the troubleshooting tips to no avail. If I press, and hold, the translucent button on the bottom of the Tempest the led won’t come on. Battery is fully charged and Tempest is next to Hub. Any suggestions?

I had the same issue. Only way I could get a reconnection is to delete everything in the app and start over. I think that means all my previous data is gone?

Try flipping the switch off and on a few times then see if the LED comes on. If it does but doesn’t connect, hold the button down for 10 seconds until you see a fast blink and go in to the app and do a Replace Device with it. It is likely that the hub will realize that it was already connected and immediately start working or it will go through the full process and start working again. Using Replace Device preserves the historical data.

@adbooth1, send support a message asking that they merge your old data with the new. You might need to give your old and new Station ID so they can find it.

UPDATE: I spoke with support, they tried to get it working with no results so they’re replacing the Tempest.

1 Like

They were able to link my old data. Thanks for the suggestion!

1 Like