No Temperature Reported (resolved)

For some reason I am not getting any tempature from my unit. Everything else on it is reporting fine.

Pictures are attached showing this.

Any ideas? I have only had my setup for about 3 weeks.

image image

its not only your temperature, your pressure also lacks data points, your humidity is mostly 100%.
Is there perhaps water inside the unit? your humidity might indicate that.
One other thing to check is the strength of the radio signal. In the app, go to settings/stations/Miami ave. If you click on the status near the bottom of the screen, you should see some RSSI values. If they are -80 (I don’t know the exact number) or even more negative, your device might experience connection problems.


Here is what I am seeing. The unit is about 30 feet away from the hub.

I have gone outside and moved it. And am getting readings again.

This is where is was mounted. On the shady side of tree.

Now I have it just sitting on a table on the side of the house.

1 Like

@scott Good to see your AIR is working again. I see in your screenshot that AIR’s RSSI (Received Signal Strength Indicator) value was -68 dBm. That is a good to fair value. These values range from 0 to -100. The closer to 0 the better. I would be more worried about the Sensor Status in the screenshot that showed TEMPERATURE_FAILED | RH_FAILED. If you had the AIR mounted to the side of the tree exposed to the elements then that may be the cause of the sensor failure that resulted in you getting no temperature and dew point data. Try to keep AIR covered from the elements. If you want to keep it out in the yard then place it inside a Stevenson Screen. That will ensure it is protected as much as possible to give you great data. Looks like all your AIR’s data is fine now. Hope you are enjoying the 72° temperature right now.

If it fails again then contact WeatherFlow Support and open a support ticket.

1 Like

Sorry but I think you’re going to have to do a reset of your hole system starting with the hub. It happened to me and that’s the only thing that works.

Hi Scott. The “FAILED” messages likely mean you have a hardware fault. If the advice from the community doesn’t help restore your values, please open a trouble ticket by sending an email to or visiting and one of our customer support gurus will help you troubleshoot and send out a replacement if necessary. Thanks!

1 Like

Yeah unfortunately it is appearing like a hardware issue. I tried the reset and still having things showing as failed and am not getting nothing from the air unit even with it two feet from the hub.

So Do what David told you. Open a support ticket and they’ll handle it from there directly with you.

I will just following up here.

But did you actually submit a support request?

Not yet. I hope to tomorrow.

Today me and my father had our Father’s Day together since we were both working last weekend.

I will get to it. :slight_smile:

As soon as you do, Support will directly contact you and resolve the issue.

Just another note… I took out the batteries this morning and put them back in and moved the air about a foot from where it was before and no the sensor status is OK.

I am not sure what fixed it but it’s working for now and I am keeping an eye on it.


2 posts were merged into an existing topic: Failure of temperature and rh sensor at the stroke of midnight