Wipe out WiFi settings

On setting up my replacement hub, my app didn’t find the WiFi network. I suspect it really was the hub that didn’t find it, since my phone had no such issue.

Anyway, in online Troubleshooting it says “To wipe out WiFi settings, press and hold the tiny button on the back of the hub for five seconds (release when LED flashes).”

My hub doesn’t have a button as such though appears to have a pin-hole reset above where the usb cable connects. However, the usual tiny click one hears/feels when using a pinhole reset doesn’t happen and there is no flashing LED. I suspect it doesn’t work…

The goods news is that I managed to get the connection going, though, by resetting my router.

Since it was somewhat troublesome to get a replacement hub here in Costa Rica, I wonder if I should be worried with a faulty reset pinhole button or might there be another way of resetting the hub, should it be necessary in the future?

Please clarify if the hub actually has a pinhole reset or not. It certainly doesn’t have a typical button.


You may not actually be pressing the switch. Adjust the angel of pin until you feel the switch.

1 Like

Thanks for confirming that it is indeed a pin-hole reset button.

I started off thinking it might be a question of a slight mis-alignment but I cannot find the switch. My preferred weapon of choice is paper clip but I also tried gently with a needle. However, to no avail, so I guess I just hope that the hub will not need to be reset…



If you dare, you can gently remove the bottom and inspect the internal circuit. It’s not difficult if you have experience repairing anti-aircraft missiles or small electronics. Otherwise I would not worry about it. WeatherFlow stands behind the hardware and offers great support.

1 Like

I will keep that in mind should a reset be required in the future. Thanks for responding to quickly - have a good one!

you might have run in the know problem that it doesn’t work very well if your network has both 2.4 and 5 Ghz enabled with the same ssid. It should (because it doesn’t have 5Ghz but there is a problem anyway, for some reason) (and yes all my other equipment runs just fine when both frequencies are enabled on my router)


My WiFi bands are configured with different SSIDs. I believe the issue was related to not starting off adding a replacement hub to the previously defined station. Instead I created a new station and could not delete the previous (I had to revert back to the first defined).

1 Like

Make sure you press and hold… not just ‘click’ the button.


I did follow the guideline pressing and holding for 5 sec but there was no flashing. Thinking the pin-hole button was misaligned a little I tried changing the angle in various directions but to no avail. As mentioned a reboot of my router solved the problem.

Like GayFunk said, an option would be to remove the bottom piece of the hub, which I’d do should it be necessary in the future.

I think I’m good but thanks to everyone!