Can't add Sky to Hub - "Hub Not Connected"


I’m trying to add the Sky, which arrived the other day but the Hub is being stubborn.

I followed the steps:

  • Start the app
  • Tap the settings icon
  • Tap Station
  • Tap [Station Name]
  • Tap Manage Devices
  • Hit [+] to add a new device

The Android App consistently says:
Hub Not Connected
Make sure HUB has power and is within 10 feet. You may need to restart the app, or cycle the power on your HUB.

I have/am

  • Within 3 metres of the Hub
  • Restarted the Hub 2 or 3 times
  • Enabled Bluetooth
  • Allowed Location permission for the App on the phone


  • the LED is blue on the hub
  • when i hit “WiFi Setup” in the station settings, the app shows the same “Hub Not Connected” message
  • I tried setting it up with another phone, same issue.
  • The main phone is Android 8.1
  • I can see the Hub has an IP address assigned at the router.
  • Hub says it is on Firmware 47
  • The hub has an Air added that is reporting data OK.

Everything looks OK so I’m a bit flummoxed as to why the Hub is not connecting. Any tips?


Do you have more than one Hub?

…or more than one phone/tablet connecting via Bluetooth???

I kept getting that error when trying to add my Sky using iOS. Force quitting the app and restarting it got things going again.

If there is only one Hub, remove the uninstall the application then install if fresh from Google.

Hi, I finally got it connected, I had to turn on Location (GPS) on the device withe app and wait a little bit.
I found out by trying to add a Sky on an Android 6 phone with Location enabled. I turned off Location on the Android 8 phone and tried to access the Wifi Setup - app gave me the Not Connected message, once I re-enabled Location and waited a bit the Wifi settings for the Station were available.

Thanks for the tips, the Sky is reporting… now I just have to find a site for it.