System Installation interface

New client system installation issues (Android App):
I would like to take this opportunity to share my difficulty with an apparent flaw in the installation interface, and lack of live installation support, which support would have been very helpful.

As I was attempting to set up the hub, it and the app got confused after I entered the wrong LAN password, and didn’t get the hub linked with my router. There was no apparent way to start the installation over from within the app. I messed around for about 2 hours trying to get the hub working. I tried resetting the hub several times (and unplugging the hub), in combination with other efforts, along with deleting and reinstalling the app.

I kept getting to a point in the App where I could do nothing to go forward. Each time I tried to add the devices, I would get the error that the hub was not connected (To what: my app or the network? Apparently it was referring to the network), but I was never able to directly address that issue from within the app. Finally, after various combinations of efforts, which I don’t recall exactly how it happened; it just magically happened; the hub finally, once again, asked me to set up the network link, and I was able to proceed.

It was very frustrating with no live support to help out. There definitely needs to be a way to start the installation over built into the installation interface. To sit there with that error message, with no path in the interface to resolve it, was very frustrating. Hopefully sharing these concerns will be helpful.

I had a similar experience upon first installation: I got ‘device not found’ message after inputting my device serial number. I could get no further. I went to bed. Got up in the morning and it was working. Overnight it had accepted my device number apparently all by itself.

I have the same problem with a new setup… I cant get past the “Enter hub serial number”
I can see the hub in my phone bluetooth available for pairing so why is this app not working? Where is the support?

It doesn’t even seem like that app is even trying to connect… it instantly says “device not found”

I can’t proceed… this device is too expensive to have this problem

I am also getting the device not found error. Have reset the device and but no change. The comments about a lack of instruction about this coupled woth no phone support make this frustrating as there is not enough information to be able to solve issue. I also deleted app and tried again but cant get past this issue.

Do you have Bluetooth enabled on your phone/tablet? Is location services also on? Sometimes that is needed, probably for getting the GPS position of the station. Does the light on the hub come on a short while after it is plugged in?

Yes I have bluetooth on and location services on. the light comes on after a short while flashing blue. Then it cant find what ever it is looking for and asks to try again. I have tried this on two different pixel phones with same result. The FAQ mentioned the need for gps and bluetooth to be on and i made sure of it for the last 20 times that i have tried to pair it. No luck… removed all other bluetooth devices like headsets from the room. still no luck. quite frustrating what is the app looking for, the hub or the weather sensor at this point? i am quite close to the unit with my phone, the sensor is blinking green. The hub is blinking blue or blue white and then nothing happens. Nothing at all. I have moved into the den to ensure a strong wifi system. I use a pfsense box for my router and unifi products for my wireless internet with strong signal at the location where i am pairing. any advice or knowledge about what i am trying to do to the device found would be helpful. have invested about six hours so far today trying different combinations of charger cable, power supply, phone and phone settings with out making any progress.

just tried again a couple of more times. It does take a few seconds for the hub color to come up to blue after replugging it. THe green light on the sensor just flashes. The blue light is flashing on the hub. Sometimes the hub light will be solid red and then the app will find it and it will turn blue. I have no idea what needs to be connecting. I went back into the specific app and checked that location is on and that it has all the permissions needed. Nothing works. Reset the base again and reset the hub. No difference. Please let me know if I can telnet into the base some how and set it up that way or some way that actually works. I have a lot of networked devices in the house so have a reasonable amount of hardware and network knowledge. What is the hub looking for, internet or the tempest control box?

I am tired of working on it since I got it this afternoon out of the box. I am going to bed. I have kept all the shipping materials so it can be returned if the connection continues to fail.

turn the Tempest off, you first have to get the hub running correctly before you add the Tempest.

Just your phone, the hub and wifi

You need to pair your hub to the 2.4 Ghz network and create it’s account on the Weatherflow servers. Once that has succeeded and only then turn on the Tempest and add it to the hub. It won’t work as long the hub isn’t correctly configured.

wifi <-2.4Ghz-> hub <-915Mhz-> Tempest

here is a detailed setup page :

troubleshooting page :

1 Like

It sounds like you have covered all the bases. I’m not sure, but just in case, do as @eric said and keep the Tempest off until you get the hub setup.

As for your network setup, if you can’t connect to the hub with Bluetooth, your WiFi isn’t even in the picture yet. Bluetooth via the app is the only way to set up the hub.

I don’t recall anyone having issues using Pixel phones to set up the hub. If you have some other mobile device, give it a try, even if it is a friend’s device you use temporarily. It should not be difficult to setup. Most have it going within just a few minutes so there may be an issue with your hub. You may want to open a support using the link above. Be sure to include a link to your first post in this thread so support can see what you have tried.

I have a Pixel-3a and did my field test Hub without issues. Also added/deleted devices from my old Air/Sky hub, and added the production Tempest to the field test Hub with zero issues. Super fast.

I turned off the tempest as discussed. I went to a third phone after the pixel 3 and pixel 3 a and now I am using an older moto X4 which does exactly the same behavior. I loaded and logged into the app. Then I connected to the hub and the light turned blue and flashed to a light blue. Then it went looking for the hub. The app showed a screen with the tempest base flashing a green light. You hit the next button for the hub to turn blue. Then it goes into some kind of loop looking for the location even though the map on each phone shows my exact location and location services are all on. This is incredibly frustrating as there is no indication of what it is looking for and what is not being found for the successful setup. 3 different phones, all with location and blue tooth setup and working on other bluetooth devices (the pixel 3 is used with android auto and works/navigates fine along with two different bluetooth headsets) All devices are completely up to date. I use a pfsense firewall and unifi AP wireless access points. What is it looking for? I broadcast my ssid for the 2.4 and 5 mhz access points and there are other wireless networks from surrounding houses but nothing shows up and it stays in this loop. I have spent 10 hours working on different combinations including removing all the other bluetooth devices from the area. Rebooting each phone. Making sure each phone has location and bluetooth on. Verifying the bluetooth operation prior to pairing with hub. verifying map location prior to pairing with hub. This is getting a bit ridiculous. Trying to connect to hub with Tempest on and Tempest off. Putting tempest outside to get more power from the solar panels. Rinse and repeat and nothing. Now what.

again somehow your hub is not configured at all. You created an account but there is no hub.

Did you go true the part where you have to give your wifi details so it can join the wifi network and from there reach internet ?? As long this is not done, nothing else will work.

Are the 2.4 and 5 MHz SSID the same name? If they are rename one of them and try them setup again.

Ok. I took an old ASUS RTAC86U Router and set it up as a wireless AP with only 2.4 MHZ. That did not work. I then tried to do the setup with my phone on LTE data to see if it would work but it did not. I then turned off the filtering program (pfblockerng) on my router for advertisements. That did not work. I scanned all my router logs for blocked attempts from connection from the IP address of the hub but there were none. I also turned off the phone each time and tried all these ideas on three phones. Pixel 3, Pixel 3A and a Motorola. Nothing worked. Then i rebooted the Pixel 3 for the umpteenth time and saw the weatherflow program. No Tempest no hub but the program loaded to the data screen for the first time. (which I do not know why it suddenly came up) I went to the settings screen and saw the original attempt that I made for the weather station. I was able to go into the hub and activate the wi fi!!! Yay. The light went green. I then went back into the program to adopt the tempest but it could not be found. I tried multiple times but it was never found. Then I wondered if the wifi might somehow affect it, so drove over to the local shopping area and hooked the hub up to my truck usb 5 volt power and again attempting pairing with the hub but with no wifi. The hub was now blue in the bluetooth pairing mode but never found the tempest. I reset the tempest and got the quick green flash and then flashing green light, but it will not connect to the hub. Brought the hub back home disappointed and put the tempest turned on out in the sunlight on the hope that maybe the charge was too low for connecting. An hour in the afternoon sun and still it will not connect. Will try it again tomorrow. I do not think I have ever had to work this hard to get something to connect. I have telnetted into embedded devices and done code by hand to make them work and even built computers back in the day with CPM,(before DOS) and must say this is frustrating. Any type of connection that would provide an idea on why the connection does not work would be much appreciated. What am I missing (except the weather data :slight_smile: ? If you check my account you should now see the hub but no Tempest. Also, if I send you the Tempest serial number could that be put in remotely on your end to make the system work?

Also, the wireless link is stable. I am showing a wifi connection of 11ng at 2.4Ghz with a signal of -59db. transmit rate is 72.2 Mbs and receive rate is 64.9 Mbs. so far the hub has recieved 600kbs down and .99 MB up. The Name is WeatherFlow which is a nice touch on your end. Most wifi systems are unnamed and you have to do a fingerprint to figure out the sender unless you cross check the mac address.

if you can input the tempest link information on your end, the serial number is 3213.

Gary can’t see much else you can, I do have some extra but not coders level.

I see indeed that you have a running hub but I do see also the first attempt to create the account made a link

Can you see in the app 2 stations by any chance ?? I think this is now preventing the Tempest to connect to the ‘active’ hub account server level.

If you see both it is possible to delete one by swiping to get the delete button in the app.
If not I’ll ask a coder (hopefully one is on watch today …) to delete all except the active hub.

I completely disconnected my internet system. I had a couple of AP’s to help with signal strength. I disconnected everything. Then I setup an ASUS RT-AC86U as a dedicated router. I only turned on the 2.4Ghz radio. One wire from the modem to the router. no wires from the router. Only the wireless access on only the 2.4Ghz radio. Tried it multiple times with the system all in the same room. Reset the hub, and it shows online from my account. Tried to locate the tempest. Flashing green light. Never found it. Reset the tempest by pushing the button. Never found the tempest. Hub shows blue light for bluetooth control. Never found the tempest. I can not do anything else. Tried several different 5.0 volt power supplies and several different cables. Nada. If it will not connect with a dedicated router with only a 2.4Ghz radio, I have nothing left in the quiver to try. I have boxed it up and await replacement instructions.

Did you try a long push on the Tempest ? More than 10 seconds to do a complete reset ??
You push till it starts to blink and then you release the button. Not before which is just a reboot command