What has happened? Lost data

For some unknown reason, things have gone haywire. I’ve been running WF OK for over 6 months, with few problems. A week ago, I changed the batteries in SKY, despite their reading sufficient, and for 3 days it worked fine. Then the flatlining started again.
It is apparent that the faults are random, often at times when there are no humans doing anything, and we have had no problems with Internet connections or any other problem.

On Weather Display, the data flatlines during these ‘pauses’.

Anyone got a clue why this behaviour has started for no apparent reason? Please?

Second picture shows your station as offline, hence no communication between hub and the servers from WF, internet problems? No link between hub and your router ???

Thank you, Eric. I agree with you. We have no known internet problems, everything working as normal except WF. And why would that suddenly cause problems between hub and SKY/AIR? These problems have appeared in last 2/3 weeks, mainly with intermittent flatlining, without my being able to think of a cause.

Just a suggestion, but could be something else:
It might be poor wireless reception. Your Hub, Air and Sky all have an RSSI value. It is a reading of the signal strength from the device to where it is sending its data to. The more distance or objects between each device will reduce this value (a greater negative number). You can see all the values in your status page. If you change the number in this link to suit your station address you should find your RSSI values. https://smartweather.weatherflow.com/settings/station/4555/status
The worst value my Sky could still operate at was -93. Usually my sky above my 2 story house has an RSSI of -68. My hub about 5m and through one wooden wall to my wifi router has an RSSI of -53.
For more info search on ‘RSSI’

The Sky or Air batteries are generally fine down to about 2V. I change my alkaline when they get down to 2.2V so that I dont risk loosing data.

cheers Ian :slight_smile:

1 Like

Thanks for the suggestion, Ian.
The RSSI numbers are
HUB -43
SKY -51 (one brick wall, about 7 m)
AIR -67 ( corner brick wall, about 8 m)

Reading on Wiki,

Thus, when an RSSI value is represented in a negative form (e.g. −100), the closer the value is to 0, the stronger the received signal has been.

I guess the problem isn’t there.

1 Like

those numbers are indeed correct and show that all devices can communicate without problems (at the moment you took the numbers).
But we still don’t have your station number … hard to have a look and try to identify something. If you could copy the link down the page (mentioning share), that might help some of us looking your data and … staff

1 Like

Sorry, the ID is 5390

Station ID5390
Serial NumberHB-00000280
Firmware Revision105
Last State Changed2019-04-20 8:00:11 PM
Uptime0d 0h 0m 43s
Last Status Time2019-04-20 6:52:18 PM
Last Hub Time2019-04-20 6:52:18 PM
Device ID15967
Serial NumberSK-00004288
Firmware Revision43
Last Observation (via app)2019-04-07 9:44:13 PM
Last Observation (via Hub)2019-04-21 11:15:56 PM
Last Observation2019-04-21 11:14:56 PM
Observation Count (last 24 hours)1
Uptime7d 8h 54m 2s
Battery3.12 volts
Sensor StatusOK
Last Status Time2019-04-21 11:15:56 PM
Last Hub Time2019-04-21 11:15:56 PM
Last State Changed2019-04-22 12:20:13 AM
Device ID15968
Serial NumberAR-00010320
Firmware Revision20
Last Observation (via app)2019-04-07 9:44:13 PM
Last Observation (via Hub)2019-04-20 6:22:42 PM
Last Observation2019-04-20 6:22:00 PM
Observation Count (last 24 hours)0
Uptime6d 4h 14m 6s
Battery2.93 volts
Sensor StatusLightning Disturber
Last Status Time2019-04-20 6:22:41 PM
Last Hub Time2019-04-20 6:22:41 PM
Last State Changed2019-04-20 8:00:12 PM

I saw there were already gaps indeed before the latest one. That WD has the same problem with data gaps indicates the hub seems not to send data at all, not to the F servers and not via UDP …
Let’s call the help from @anon84912554 Maybe they can see something in the raw data ???
And you can also open a ticket directly via

support via the website : http://got.wf/contact
support via mail : support@weatherflow.com

they should come back to you quickly.

1 Like

Thanks, Eric.

I tried the website, but it would not accept my password nor allow me to change it, so I tried the e-mail address a few days ago with no response.

I don’t like to say this but I’m close to binning WF. Happily, I have two other weather stations that keep me up to date with what’s going on.

Hello @bne

not sure why no one is answering you but I just pushed someone to get back to you. Hope you get a solution quickly now.

Thanks muchly, eric!

Hi. There’s definitely something anomalous going on here. At first glance, it looks like something is up with your hub. We will take a look at your data and get back to you with suggestions ASAP.

1 Like

Great, thanks in advance for your help! :slightly_smiling_face:

Hi Brian! I’m guessing power cycling the Hub by unplugging it for a few moments doesn’t keep the problem solved for too long? If that’s the case, you might need a replacement Hub.

By the way, did you contact customer support? I tried looking for any requests under your e-mail “bne@bnellis.eu” but couldn’t find anything recent.

Yes, I copied this file to the support email address but I admit I can’t find my copy.

Subject to a 24 h test, I think I may have found the cause of the problem. It may be that the 5 V PSU feeding HUB was giving all sorts of anomalous values ranging from 0 to 5 V, apparently at random. I have changed it for a different PSU and, touch wood, it seems OK after only 2 h. (Discovered the anomaly when I ‘borrowed’ the 5 V from it to try another unrelated job)

Watch this space!


Seems the problem is now solved. Two+ days without a glitch. Old PSU now sent for recycling.