Air not reporting data

air is not reporting data. Frozen with readings from 6 hr ago. In settings for Air tried too connect to Hub but after several tries with power cycling it will not connect. WiFi setup will not advance past the cannot Connect to Hub msg. Sky functions fine.

Replaced batteries in Air and no joy.


Does this is independent from the distance between Hub and Air ?

What are the last RSSI values for Air?
What is your stations ID?

Well the system started working properly overnight. Did not change anything from my initial unsuccessful attempts via power cycling. So guess it’s a mystery

Mysteriously the following day it began updating and displayed current conditions. Today only displays conditions from 22 hours ago. Rebooted router and hub without improvement. Am 10 feet from hub and router, a spot where it has always worked.
Station 12772
RSSI. -46

Deleting and reinstall app seems to have fixed it. We will see.

I thought we used to have air density readings on the more detailed page. Went there today and do not find air density. Am I looking in wrong place? If not can we get this parameter back?

Reappeared when I deleted and reinstalled the app

1 Like

it was IOS, however after I deleted the app and reinstalled it it did reappear. A more useful value would be Density Altitude measured in feet rather than air density in lbs/ft3 IMO. Density Altitude is used by precision shooters, sky divers and aviation.